HealthyPC - N-Central Outage – Incident details

All systems operational

N-Central Outage

Resolved
Major outage
Started 1 day agoLasted about 2 hours

Affected

Hosted Cloud Solutions

Major outage from 11:44 PM to 1:20 AM

N-central

Major outage from 11:44 PM to 1:20 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating this incident. affecting the N-central and Take Control services