HealthyPC - Degraded Network Performance – Incident details

All systems operational

Degraded Network Performance

Resolved
Operational
Started about 1 month agoLasted 5 days

Affected

Hosted Cloud Solutions

Degraded performance from 1:06 AM to 2:54 AM

RDP Cloud Services

Degraded performance from 1:06 AM to 2:54 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently aware of a fault causing intermittent freezing and slowness issues within our RDP cloud services network. Our team has identified the fault and are working on a resolution