HealthyPC - RDP Cloud Services Not accessible – Incident details
Report an issue
Get updates
Email
Microsoft Teams
RSS
Atom
Report an issue
Get updates
Dark mode
All systems operational
RDP Cloud Services Not accessible
Resolved
Operational
Started about 2 months ago
Lasted about 2 hours
Affected
Hosted Cloud Solutions
Major outage from 11:50 PM to 1:46 AM
RDP Cloud Services
Major outage from 11:50 PM to 1:46 AM
Updates
Resolved
April 03, 2025 at 1:46 AM
Resolved
April 03, 2025 at 1:46 AM
This incident has been resolved.
Investigating
April 02, 2025 at 11:50 PM
Investigating
April 02, 2025 at 11:50 PM
We are currently investigating this incident.